Issues Loading Site
Incident Report for Kickstarter
Resolved
We had a temporary database issue that seems to have passed (without our intervention). We will continue to investigate the cause, but the site is fully operational at this time.
Posted Jul 25, 2014 - 14:05 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 25, 2014 - 13:34 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 25, 2014 - 13:26 EDT
Investigating
We're currently experiencing some site issues. If you're unable to load pages on the site, please try again in a bit.
Posted Jul 25, 2014 - 13:19 EDT