Site is Down
Incident Report for Kickstarter
Resolved
This incident has been resolved.
Posted Feb 25, 2015 - 14:05 EST
Monitoring
Looks like we're back up and running. We'll keep an eye on things for a bit.
Posted Feb 25, 2015 - 13:53 EST
Update
Our developers are still working to bring the site back up. Thanks for your patience and understanding.
Posted Feb 25, 2015 - 13:16 EST
Update
Our developers are still hard at work investigating the issue.
Posted Feb 25, 2015 - 12:42 EST
Investigating
We are investigating the issue.
Posted Feb 25, 2015 - 12:00 EST