Maintenance Window
Incident Report for Kickstarter
Resolved
Maintenance on the site has been completed and all services are back to normal, thank you for your patience.
Posted Oct 23, 2014 - 23:28 EDT
Identified
We will be conducting a short maintenance beginning at 11pm EDT, the site will be down for approximately 10 mins.
Posted Oct 23, 2014 - 22:36 EDT