Creator's project activity view broken
Incident Report for Kickstarter
Resolved
We've fixed the project activity section of the creator dashboard.
Posted Sep 05, 2014 - 13:36 EDT
Identified
We've identified a problem with creator's project activity. Should have a fix in a few minutes.
Posted Sep 05, 2014 - 13:26 EDT