Adding a new card during checkout process is broken
Incident Report for Kickstarter
Resolved
Thanks for your patience!
Posted Mar 13, 2015 - 16:37 EDT
Identified
A fix is going out shortly. In the meantime, pledging using a new card works in our iOS app.
Posted Mar 13, 2015 - 16:28 EDT
Investigating
Developers are working on a fix now!
Posted Mar 13, 2015 - 16:24 EDT