Amazon mobile login failures for some users
Incident Report for Kickstarter
Resolved
This appears to have been a temporary issue that has passed. We will continue to monitor for any new reports.
Posted Aug 08, 2014 - 08:25 EDT
Identified
We have received reports of some, but not all, users seeing errors while logging into Amazon via a mobile device. We have reached out to Amazon to inform them of the issue.
Posted Aug 07, 2014 - 16:31 EDT