Approved Project Creators Not Seeing Launch Button
Incident Report for Kickstarter
Resolved
Creators should now be seeing what they are supposed to see. Thanks for your patience!
Posted Mar 13, 2015 - 17:00 EDT
Identified
We're working on a fix now.
Posted Mar 13, 2015 - 16:46 EDT
Investigating
Our developers are looking into this now. Thanks for your patience also!
Posted Mar 13, 2015 - 16:38 EDT