Site slowness and errors
Incident Report for Kickstarter
Resolved
Site's back up. Thanks for your patience!
Posted Mar 17, 2015 - 15:47 EDT
Identified
Our developers are working on a fix to get the site back up. Sorry for the inconvenience!
Posted Mar 17, 2015 - 15:33 EDT
Investigating
We are currently looking into a caching issue causing site slowness and intermittent errors.
Posted Mar 17, 2015 - 15:21 EDT