Kickstarter Outage

Incident Report for Kickstarter

Resolved

The issue has been resolved and we will continue to monitor to make sure things look clear.
Posted Dec 05, 2025 - 04:17 EST

Investigating

We are currently investigation the issue. We are sorry for any inconvenience.
Posted Dec 05, 2025 - 04:10 EST
This incident affected: Kickstarter.com, Payments, and Mobile.