Images, videos, and other assets not loading
Incident Report for Kickstarter
Resolved
This incident has been resolved.
Posted 10 months ago. Jun 26, 2018 - 16:06 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 10 months ago. Jun 26, 2018 - 16:05 EDT
Investigating
Our developers are currently investigating an issue with images, videos, and other assets not loading. Thanks for your patience while we look into this!
Posted 10 months ago. Jun 26, 2018 - 15:40 EDT
This incident affected: Kickstarter.com.