Issues pledging on site
Incident Report for Kickstarter
Resolved
All-clear! We've been monitoring the site and everything looks good. Sorry for any trouble.
Posted 10 months ago. Feb 21, 2017 - 16:08 EST
Monitoring
A fix has been implemented and we're standing by to make sure everything runs smoothly.
Posted 10 months ago. Feb 21, 2017 - 15:49 EST
Identified
We've discovered what's causing this issue and we're working on a fix. Thanks for your patience!
Posted 10 months ago. Feb 21, 2017 - 15:49 EST