Login button on Chrome
Incident Report for Kickstarter
Resolved
This incident has been resolved.
Posted Sep 14, 2023 - 19:15 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 14, 2023 - 19:12 EDT
Investigating
We're currently experiencing an issue with logging in on Chrome where the button is not appearing. We're on it!
Posted Sep 14, 2023 - 17:53 EDT
This incident affected: Kickstarter.com.