Loading project dashboards
Incident Report for Kickstarter
Resolved
Project dashboards are loading properly again! Carry on.
Posted over 1 year ago. Aug 19, 2016 - 13:29 EDT
Identified
We've identified an issue loading project dashboards. Should be fixed soon!
Posted over 1 year ago. Aug 19, 2016 - 13:16 EDT