Site is down
Incident Report for Kickstarter
Resolved
All-clear! We've been monitoring the site and everything looks good. Sorry for any trouble.
Posted 11 days ago. Dec 04, 2017 - 14:26 EST
Investigating
Our developers are currently investigating. Thanks for your patience while we look into this.
Posted 11 days ago. Dec 04, 2017 - 14:23 EST