Delayed Processing Times
Incident Report for Kickstarter
Resolved
This issue has been resolved. We corrected an issue where some pledges were getting counted twice inside creator dashboards, this has been corrected.
Posted Feb 14, 2020 - 21:15 EST
Update
We are working on a fix for creators dashboards where some pledges got counted twice, this only affects these statistics and not the actual pledges.
Posted Feb 14, 2020 - 20:44 EST
Update
This issue has also caused people to receive duplicate emails and push notifications from our site. We are continuing to monitor the changes.
Posted Feb 14, 2020 - 19:36 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 14, 2020 - 19:24 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 14, 2020 - 18:25 EST
Investigating
We are currently investigating an issue that is resulting in delayed processing times for email responses, image processing, and push notifications.
Posted Feb 14, 2020 - 17:27 EST
This incident affected: Kickstarter.com, Payments, and Mobile.