Site operational
Incident Report for Kickstarter
Resolved
This incident has been resolved.
Posted 13 days ago. Aug 06, 2018 - 19:01 EDT
Update
We are continuing to monitor for any further issues.
Posted 13 days ago. Aug 06, 2018 - 16:11 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 13 days ago. Aug 06, 2018 - 15:51 EDT
Update
We are continuing to investigate this issue.
Posted 13 days ago. Aug 06, 2018 - 15:47 EDT
Investigating
We are currently investigating this issue.
Posted 13 days ago. Aug 06, 2018 - 15:47 EDT
This incident affected: Kickstarter.com, Payments, Mobile, Drip, and Kickstarter Live.