Project dashboard down for all
Incident Report for Kickstarter
Resolved
All-clear! We've been monitoring the site and everything looks good. Sorry for any trouble.
Posted 5 months ago. Jan 17, 2017 - 15:30 EST
Identified
Project dashboard is down. We've discovered what's causing this issue and we're working on a fix. Thanks for your patience!
Posted 5 months ago. Jan 17, 2017 - 15:28 EST