Upstream Payment Processor Outage
Incident Report for Kickstarter
Resolved
This incident has been resolved.
Posted about 1 month ago. Jul 10, 2019 - 19:43 EDT
Monitoring
The upstream issue has been resolved and we are monitoring the results.
Posted about 1 month ago. Jul 10, 2019 - 19:10 EDT
Investigating
Adding a new payment source is currently not working due to an issue with our upstream payment processor.
Posted about 1 month ago. Jul 10, 2019 - 18:58 EDT
This incident affected: Payments.