Payments issue
Incident Report for Kickstarter
Resolved
All-clear! We've been monitoring the site and everything looks good. Sorry for any trouble.
Posted 15 days ago. Nov 08, 2017 - 13:32 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 15 days ago. Nov 08, 2017 - 13:23 EST
Investigating
Our developers are currently investigating an issue with [INSERT]. Thanks for your patience while we look into this!
Posted 15 days ago. Nov 08, 2017 - 13:23 EST