Issues with processing payments
Incident Report for Kickstarter
Resolved
All-clear! We've been monitoring the site and everything looks good. Sorry for any trouble.
Posted Jun 20, 2017 - 14:28 EDT
Investigating
Our developers are currently investigating an issue with payments. Thanks for your patience while we look into this.
Posted Jun 20, 2017 - 14:18 EDT