Problems managing pledges
Incident Report for Kickstarter
Resolved
All-clear! We've been monitoring the site and everything looks good. Sorry for any trouble.
Posted 4 months ago. Apr 10, 2017 - 13:07 EDT
Monitoring
A fix has been implemented and we're standing by to make sure everything runs smoothly.
Posted 4 months ago. Apr 10, 2017 - 12:57 EDT
Identified
We've discovered what's causing this issue and we're working on a fix. Thanks for your patience!
Posted 4 months ago. Apr 10, 2017 - 12:31 EDT