Currently experiencing slow response times
Incident Report for Kickstarter
Resolved
This incident has been resolved.
Posted Apr 17, 2023 - 18:11 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 17, 2023 - 15:51 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 17, 2023 - 14:50 EDT
This incident affected: Kickstarter.com.