Issue with story and project update editors.
Incident Report for Kickstarter
Resolved
This incident has been resolved.
Posted Mar 11, 2024 - 18:30 EDT
Update
All-clear! We've been monitoring the site and everything looks good. Sorry for any trouble.
Posted Mar 11, 2024 - 18:30 EDT
Update
A fix has been implemented and we're standing by to make sure everything runs smoothly.
Posted Mar 11, 2024 - 18:26 EDT
Investigating
We're currently experiencing an issue with our story editor and project update editors. Some creators may notice these are not displaying correctly. We're on it!
Posted Mar 11, 2024 - 18:02 EDT
This incident affected: Kickstarter.com.