Issue loading project pages
Incident Report for Kickstarter
Resolved
All-clear! We've been monitoring the site and everything looks good. Sorry for any trouble.
Posted 10 months ago. Oct 11, 2016 - 17:28 EDT
Monitoring
A fix has been implemented and we're standing by to make sure everything runs smoothly.
Posted 10 months ago. Oct 11, 2016 - 16:43 EDT
Identified
Our developers are currently investigating an issue loading project pages. Thanks for your patience while we look into this!
Posted 10 months ago. Oct 11, 2016 - 16:31 EDT