Site down
Incident Report for Kickstarter
Resolved
This incident has been resolved.
Posted 22 days ago. Oct 29, 2018 - 14:00 EDT
Investigating
We are currently investigating this issue.
Posted 22 days ago. Oct 29, 2018 - 13:47 EDT