Some emails not getting sent
Incident Report for Kickstarter
Resolved
This incident has been resolved.
Posted Oct 25, 2024 - 11:06 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 24, 2024 - 14:11 EDT
Investigating
Thanks for your patience while we look into this!
Posted Oct 24, 2024 - 12:49 EDT
This incident affected: Kickstarter.com.