Payments issue
Incident Report for Kickstarter
Resolved
This issue has been resolved, and we're keeping an eye on site performance to make sure everything is working smoothly. Please stay tuned for the all-clear.
Posted about 1 year ago. Sep 22, 2017 - 15:16 EDT
Investigating
Our developers are currently investigating an issue with payments. Thanks for your patience while we look into this!
Posted about 1 year ago. Sep 22, 2017 - 15:07 EDT