Creator Sidebar Missing from Successfully Funded Projects
Incident Report for Kickstarter
Resolved
This incident has been resolved.
Posted 7 months ago. Sep 16, 2016 - 17:51 EDT
Monitoring
A fix has been implemented and we're standing by to make sure everything runs smoothly.
Posted 7 months ago. Sep 16, 2016 - 17:45 EDT
Identified
The Creator Sidebar is missing from successfully funded project pages. We’re working to resolve this issue, and hope to have it all fixed soon. Thanks so much for your patience and understanding, and sorry for any inconvenience.

In the meantime, you can access these pages by appending these strings to the end of your full project URL:

Backer Report: /report/index
Dashboard: /dashboard
Updates: /posts/new
Surveys: /surveys
Posted 7 months ago. Sep 16, 2016 - 17:28 EDT