Delays in some site operations

Incident Report for Kickstarter

Resolved

This incident has been resolved.
Posted Jul 30, 2020 - 16:45 EDT

Monitoring

We've implemented a fix and are monitoring the solution.
Posted Jul 30, 2020 - 15:38 EDT

Identified

We're experiencing some delays in site functions (sending emails, etc.). We've identified the issue and are actively working on a resolution.
Posted Jul 30, 2020 - 13:50 EDT
This incident affected: Kickstarter.com.