Project build not loading
Incident Report for Kickstarter
Resolved
All-clear! We've been monitoring the site and everything looks good. Sorry for any trouble.
Posted 3 months ago. Sep 08, 2017 - 17:20 EDT
Investigating
We've identified the cause of this issue and are working to release a fix as soon as possible. Thanks for your patience!
Posted 3 months ago. Sep 08, 2017 - 16:50 EDT