A fix has been implemented and we are monitoring the results.
Posted Mar 08, 2025 - 21:08 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 08, 2025 - 21:08 EST
Investigating
We are investigating reports of backers receiving duplicated emails as well as creators having issues uploading photos. Thanks for your patience while we look into this!