Issues affecting advanced search
Incident Report for Kickstarter
Resolved
This incident has been resolved.
Posted 9 months ago. Mar 29, 2018 - 15:36 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 9 months ago. Mar 29, 2018 - 14:46 EDT
Investigating
We are currently investigating this issue.
Posted 9 months ago. Mar 29, 2018 - 13:46 EDT