Trouble serving images and videos
Incident Report for Kickstarter
Resolved
All-clear! We've been monitoring the site and everything looks good. Sorry for any trouble.
Posted 4 months ago. Feb 28, 2017 - 17:39 EST
Update
All-clear! We've been monitoring the site and everything looks good. Sorry for any trouble.
Posted 4 months ago. Feb 28, 2017 - 17:26 EST
Update
Trouble serving images and videos remains an on-going issue
Posted 4 months ago. Feb 28, 2017 - 15:52 EST
Update
Besides issues loading project images and videos, we've also identified issues loading The Creative Independent and Kickstarter Live streams.
Posted 4 months ago. Feb 28, 2017 - 13:30 EST
Identified
We've identified a problem viewing some project images and videos.
Posted 4 months ago. Feb 28, 2017 - 13:16 EST