Issues loading Kickstarter.com and pledge checkout
Incident Report for Kickstarter
Resolved
All-clear! We've been monitoring the site and everything looks good. Sorry for any trouble.
Posted about 1 year ago. Oct 25, 2016 - 18:25 EDT
Monitoring
Things are stabilizing now and we're standing by to make sure everything runs smoothly.
Posted about 1 year ago. Oct 25, 2016 - 17:25 EDT
Investigating
Our developers are currently investigating issues with pledge checkout and loading the site. Thanks for your patience while we look into this!
Posted about 1 year ago. Oct 25, 2016 - 15:44 EDT