Pledging trouble using stored cards
Incident Report for Kickstarter
Resolved
All-clear. Pledging using stored cards is working again. Thanks for your patience!
Posted 8 months ago. Oct 26, 2016 - 12:03 EDT
Identified
We've discovered what's causing this issue and we're working on a fix. Thanks for your patience!
Posted 8 months ago. Oct 26, 2016 - 11:51 EDT