Delay in charging credit cards
Incident Report for Kickstarter
Resolved
This incident has been resolved.
Posted Sep 08, 2023 - 10:17 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 07, 2023 - 16:47 EDT
Identified
A fix has been identified, we're working on getting it into production shortly
Posted Sep 07, 2023 - 15:05 EDT
Investigating
There is an issue causing delays in charging credit cards. Backings can still occur but the collections and charges on cards are delayed.
Posted Sep 07, 2023 - 14:45 EDT
This incident affected: Kickstarter.com and Payments.