Identity verification not working

Incident Report for Kickstarter

Resolved

This incident has been resolved.
Posted Feb 10, 2014 - 19:59 EST

Update

We've seen several successful attempts at UK identity verification and are awaiting word from our identity verification provider to all-clear the situation on their end.
Posted Feb 10, 2014 - 17:53 EST

Monitoring

Attempts to verify US identities seem to be going through now. We're still waiting for word from our service provider on UK identity verification status.
Posted Feb 10, 2014 - 16:52 EST

Identified

The provider has acknowledged the problem and that they're working on fixing it.
Posted Feb 10, 2014 - 15:51 EST

Update

This issue is still ongoing, though it's only affecting creators in the US and GB. We'll keep updating here.
Posted Feb 10, 2014 - 15:18 EST

Investigating

The provider we use for identity verification appears to be having issues as of approximately 30 minutes ago. Identity verification during project build is not able to be passed. We'll report back here with updates or an all-clear once they've resolved the problem.
Posted Feb 10, 2014 - 14:56 EST