Elevated Checkout Errors
Incident Report for Kickstarter
Resolved
All-clear. Thanks for your patience!
Posted 11 months ago. Jul 25, 2016 - 11:39 EDT
Monitoring
This issue has been resolved, and we're keeping an eye on site performance to make sure everything is working smoothly. We'll follow up when we're convinced that this has been fully resolved!
Posted 11 months ago. Jul 25, 2016 - 11:18 EDT
Investigating
Our developers are currently investigating an issue with checkout. This bug may temporarily prevent you from completing your pledge. We're working to resolve this matter as quickly as possible. Thanks for your patience in the meantime!
Posted 11 months ago. Jul 25, 2016 - 11:09 EDT