Site down
Incident Report for Kickstarter
Resolved
All-clear! We've been monitoring the site and everything looks good. Sorry for any trouble.
Posted 7 months ago. Feb 27, 2018 - 16:02 EST
Update
A fix has been implemented and we're standing by to make sure everything runs smoothly.
Posted 7 months ago. Feb 27, 2018 - 15:18 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 7 months ago. Feb 27, 2018 - 15:18 EST
Investigating
We're working to resolve this issue as quickly as possible. Apologies for any inconvenience!
Posted 7 months ago. Feb 27, 2018 - 15:06 EST