Site is Down
Incident Report for Kickstarter
Resolved
This incident has been resolved.
Posted 5 months ago. Mar 07, 2017 - 18:01 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 5 months ago. Mar 07, 2017 - 15:29 EST
Investigating
We're investigating elevated error rates and slow site performance. Thanks for your patience while we look into this!
Posted 5 months ago. Mar 07, 2017 - 15:06 EST