Some creators having trouble launching projects.

Incident Report for Kickstarter

Resolved

All-clear! We've been monitoring the site and everything looks good. Sorry for any trouble.
Posted Mar 10, 2025 - 17:28 EDT

Identified

We've discovered what's causing this issue and we're working on a fix. Thanks for your patience!

The issue should be resolved for most creators but for some creators who attempted to verify their project information with Stripe between March 5 through March 10 may still be experiencing challenges. We are currently working on addressing these affected accounts
Posted Mar 10, 2025 - 13:41 EDT

Investigating

We've discovered what's causing this issue and we're working on a fix. Thanks for your patience!

The issue should be resolved for most creators but for some creators who attempted to verify their project information with Stripe between March 5 through March 10 may still be experiencing challenges. We are currently working on addressing these affected accounts.
Posted Mar 10, 2025 - 13:39 EDT

Identified

We've discovered what's causing this issue and we're working on a fix. Thanks for your patience!
Posted Mar 10, 2025 - 12:30 EDT

Investigating

We're working to resolve this issue as quickly as possible. Apologies for any inconvenience!
Posted Mar 10, 2025 - 11:23 EDT
This incident affected: Kickstarter.com.