Kickstarter Live is down
Incident Report for Kickstarter
Resolved
This incident has been resolved.
Posted about 1 year ago. Dec 08, 2016 - 11:28 EST
Update
All-clear. Thanks for your patience!
Posted about 1 year ago. Dec 08, 2016 - 11:27 EST
Investigating
Our developers are currently investigating an issue loading live.kickstarter.com. Thanks for your patience while we look into this!
Posted about 1 year ago. Dec 08, 2016 - 11:19 EST