All-clear! We've been monitoring the site and everything looks good. Sorry for any trouble.
Posted Jun 04, 2026 - 08:29 EDT
Identified
We're seeing an elevated failure rate for a variety of request types, due to server timeouts. Users who experience a failed request may find a second try will cause it to succeed.
We've discovered what's causing this issue and we're working on a fix. Thanks for your patience!
Posted Jun 04, 2026 - 08:04 EDT
This incident affected: Kickstarter.com and Payments.