Issues with 3DS card verification - Some users may be incorrectly shown a payment success message.

Incident Report for Kickstarter

Resolved

Our payment processor has fixed the bug that caused some European Apple Pay backers to be incorrectly shown success messages.
Posted 4 years ago. Mar 25, 2021 - 17:32 EDT

Update

We are continuing to investigate this issue.
Posted 4 years ago. Mar 05, 2021 - 17:55 EST

Investigating

We are currently investigating. Some users may be incorrectly shown a payment success message.
Posted 4 years ago. Mar 05, 2021 - 11:39 EST
This incident affected: Payments.