Backing projects currently down
Incident Report for Kickstarter
Resolved
This incident has been resolved.
Posted 20 days ago. May 07, 2018 - 18:19 EDT
Update
All-clear! We've been monitoring the site and everything looks good. Sorry for any trouble.
Posted 20 days ago. May 07, 2018 - 18:03 EDT
Update
This issue has been resolved, and we're keeping an eye on site performance to make sure everything is working smoothly. Please stay tuned for the all-clear.
Posted 20 days ago. May 07, 2018 - 13:50 EDT
Investigating
Our developers are currently investigating an issue with backing projects. Thanks for your patience while we look into this!
Posted 20 days ago. May 07, 2018 - 13:49 EDT
This incident affected: Kickstarter.com and Payments.