Pledging Problems
Incident Report for Kickstarter
Resolved
All-clear. Thanks for your patience!
Posted about 1 year ago. Jul 19, 2016 - 16:32 EDT
Monitoring
This issue has been resolved, and we're keeping an eye on site performance to make sure everything is working smoothly. We'll update this issue to resolved when we're satisfied that all is back to normal.
Posted about 1 year ago. Jul 19, 2016 - 15:28 EDT
Investigating
We're currently looking into a situation causing some users to encounter slow response times and issues pledging.
Posted about 1 year ago. Jul 19, 2016 - 14:33 EDT