Issues updating / submitting survey responses
Incident Report for Kickstarter
Resolved
This incident has been resolved.
Posted 2 months ago. Oct 02, 2017 - 18:20 EDT
Monitoring
A fix has been implemented and we're standing by to make sure everything runs smoothly.
Posted 2 months ago. Oct 02, 2017 - 17:59 EDT
Identified
We've discovered what's causing this issue and we're working on a fix. Thanks for your patience!
Posted 2 months ago. Oct 02, 2017 - 16:59 EDT
Investigating
Backers may experience issues updating addresses in surveys or submitting new survey responses. We're working to resolve this as soon as possible. Thanks for your patience.
Posted 2 months ago. Oct 02, 2017 - 16:12 EDT