Elevated Errors & Slow Site Performance
Incident Report for Kickstarter
Resolved
This incident has been resolved.
Posted May 18, 2023 - 19:43 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 18, 2023 - 19:29 EDT
Update
We are continuing to work on a fix for this issue.
Posted May 18, 2023 - 19:17 EDT
Identified
We're investigating elevated error rates and slow site performance. Thanks for your patience while we look into this!
Posted May 18, 2023 - 19:16 EDT
This incident affected: Kickstarter.com.