Elevated Error Rates
Incident Report for Kickstarter
Resolved
Errors on the site have been resolved, we are sorry for any inconvenience.
Posted 3 months ago. Aug 02, 2017 - 20:15 EDT
Investigating
We're investigating issues with site errors and are working to fix it as quickly as possible. Thanks for your patience, and sorry for any inconvenience.
Posted 3 months ago. Aug 02, 2017 - 19:44 EDT