Creators unable to save changes to the "Basics" tab of Project Build
Incident Report for Kickstarter
Resolved
This incident has been resolved.
Posted 20 days ago. Oct 31, 2018 - 15:33 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted 20 days ago. Oct 31, 2018 - 14:45 EDT
This incident affected: Kickstarter.com.